PPPOE拨号之一:Cisco 路由器PPPOE拨号配置 | 网络之路博客(公众号同名)(其他平台网络之路Blog)
登录
  • 欢迎网络之路博客网站,分享有用的知识点,公众号:网络之路博客,B站:网络之路Blog
  • 如果您觉得本站对您有帮助,那么赶紧使用Ctrl+D 收藏吧,支持我们下
  • 远程技术支持的淘宝店铺已经开张了哦,传送门:需要的朋友可以点击查看

PPPOE拨号之一:Cisco 路由器PPPOE拨号配置

【汇总】外网接入之PPPOE拨号

文档帖子汇总实战系列学习视频学习必备软件
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

拓扑

pppoe
在工作中,很有可能遇到的外网接入方式就是ADSL拨号了,虽然看着简单,但是这里讲讲Cisco路由器上面的一些注意事项与配置。

1、接口下调用PPPOE-client

Router-pppoe_client(config)#interface e0/0 //接外网接口
Router-pppoe_client(config-if)#pppoe-client dial-pool-number 1
Router-pppoe_client(config-if)#no shutdown

2、PPPOE-client接口的配置

Router-pppoe_client(config)#interface dialer 1
Router-pppoe_client(config-if)#encapsulation ppp 【在思科上面默认为HDLC】
Router-pppoe_client(config-if)#ip address negotiated 【地址通过协商获取】

2、可能遇到的问题

在实际环境中,不清楚运营商那边使用的是PAP还是CHAP认证,如果只配置了一种可能导致拨号失败,这里给出一种方法,可以完美解决这个问题。

Router-pppoe_client(config-if)#ppp authentication chap pap callin
然后输入pap跟chap两种方式,这样无论运营商是哪种都可以成功。

Router-pppoe_client(config-if)#ip mtu 1492
Router-pppoe_client(config-if)#ip tcp adjust-mss 1420
Router-pppoe_client(config-if)#dialer pool 1 【跟接口输入的nmuber号一致】
至此,ADSL的配置完毕了,如果帐号密码与接口没错的话,就可以获取到IP了。

3、查看是否获取到了IP

pppoe
可以看到虚拟接口已经起来,也获取到了IP地址。

4、NAT与路由配置

Router-pppoe_client(config)#ip route 0.0.0.0 0.0.0.0 dialer 1 permanent //实际环境中可能存在三层交换机,这时候需要写回程路由
该permanent参数可以让默认路由永久存在,可以根据需求来决定是否定义

Router-pppoe_client(config)#ip access-list extended nat
Router-pppoe_client(config-ext-nacl)#permit ip 192.168.1.0 0.0.0.255 any
Router-pppoe_client(config)#ip nat inside source list nat interface dialer 1 overload

Router-pppoe_client(config)#int lo 0 //说明,这个是演示,所以采用的是环回口,实际环境调用在内网接口就可以
Router-pppoe_client(config-if)#ip nat inside
Router-pppoe_client(config-if)#exit

Router-pppoe_client(config)#int dialer 1
Router-pppoe_client(config-if)#ip nat outside
说明:这里用环回口来做测试,另外nat的调用是在dialer口,而不是物理接口。

5、测试

pppoe
pppoe
可以正常访问外网了。

容易遇到的问题

(1)一些网站或者应用打开慢以及打不开的情况,这个很有可能是MTU与TCP MSS导致,可以多尝试几个值来达到比较理想的效果。
Router-pppoe_client(config)#interface dialer 1
Router-pppoe_client(config-if)#ip mtu 1492 //范围建议在1000~1492之间
Router-pppoe_client(config-if)#ip tcp adjust-mss 1420 //范围在1000~1452之间
(2)一些小企业或者SOHO级别的网络可能申请的是民用的拨号线路,那这个时候有可能自己用电脑先拨入测试效果,然后发现在路由器上面怎么都拨入不了,那很有可能是运营商那边绑定了,需要打电话过去松绑。
(3)ADSL有可能采用私网地址分配,所以在申请的时候需要考虑是否需要做映射服务出去或者一些VPN拨入,在申请的时候需要跟对方说明清楚。(包括80端口是否可以用)

关于博客资源下载说明

首先,感谢大家对网络之路博客的支持,本站所有资源都是开放下载,不做任何限制,资源都是上传在百度盘,分为两种类型:
(1)第一种是书籍PDF与视频类,全部放在博客分享,觉得对大家学习有帮助的博主会收集好、然后以博主的经验整理分类后排序好分享出来。
(2)第二种是技术性文章与视频,全部放在公众号(网络之路博客)/头条号/百家号/B站(网络之路Blog)发布,以博主原创为主,主要分享系列为主,由浅入深的带大家了解工作中常用到的一些网络技术,当然也会分享一些比较经典的案例。
(3)分享资源有涉及到您的利益以及版权问题,请联系博主,24小时候内删除。

想第一时间收到最新更新内容吗,那就赶紧关注公众号/头条/B站/百家号吧~~

学习最新实用技术

远程技术支持(设备调试)

远程技术调试与技术支持,点击查看详情


原创与收集的内容,允许转载,转载时请务必以超链接形式标明文章原始出处,博客地址http://ccieh3c.com。

喜欢 (5)
[]
分享 (0)
公众号:网络之路博客(其他平台网络之路Blog)
分享一些自己懂的技术知识点,希望对大家有帮助。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址