PPPOE拨号之六:华为路由器 PPPoE拨号配置(包含Client+NAT与服务器配置) | 网络之路博客
注册 登录
  • 欢迎网络之路博客网站,分享IT教程,推荐使用2345浏览器访问本网站,可以下载PDF与观看实战文章点击下载
  • 如果您觉得本站对您有帮助,那么赶紧使用Ctrl+D 收藏吧,支持我们下
  • 远程技术支持的淘宝店铺已经开张了哦,传送门:需要的朋友可以点击查看
  • 资源太多??下载繁琐??不知道如何学起??博主给你解决这些问题!~!点击免费下载

PPPOE拨号之六:华为路由器 PPPoE拨号配置(包含Client+NAT与服务器配置)

【汇总】外网接入之PPPOE拨号

文档帖子汇总实战系列学习视频学习必备软件
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

掌握目标

1、在华为路由器上PPPOE服务器的配置
2、在华为路由器上PPPOE 客户端的配置(工作上常用)
3、配置NAT(上网使用)
4、默认路由配置

拓扑图

pppoe

1、在华为路由器上PPPOE服务器的配置

(1)地址池配置
[HW-Server]ip pool pppoe
[HW-Server-ip-pool-pppoe]network 123.1.1.0 mask 24
[HW-Server-ip-pool-pppoe]dns-list 114.114.114.114

(2)配置虚拟模板
[HW-Server]int e0/0/0
[HW-Server-Ethernet0/0/0]ip address 123.1.1.1 24

[HW-Server]interface Virtual-Templa 1
[HW-Server-Virtual-Template1]ip address unnumbered interface e0/0/0
[HW-Server-Virtual-Template1]remote address pool pppoe
说明:这里是调用了出接口的地址,也可以手工配置,另外调用全局定义的地址池

(3)接口调用
[HW-Server]interface e0/0/0
[HW-Server-Ethernet0/0/0]pppoe-server bind virtual-template 1

(4)用户名定义
[HW-Server]aaa
[HW-Server-aaa]local-user ccieh3c password cipher ccieh3c.taobao.com
[HW-Server-aaa]local-user ccieh3c service-type ppp

2、在华为路由器上PPPOE 客户端的配置(工作上常用)

客户端的配置在企业的环境中是最常见遇到的,掌握是非常有必要。
(1)定义拨号规则
[HW-Client]dialer-rule
[HW-Client-dialer-rule]dialer-rule 1 ip permit
说明:这里就是定义的拨号规则,允许所有的IPV4流量通过。

(2)拨号接口
[HW-Client]interface Dialer 1
[HW-Client-Dialer1]dialer user ccieh3c
[HW-Client-Dialer1]dialer-group 1 (这里是关联的拨号接口)
[HW-Client-Dialer1]dialer bundle 1 (这里是定义一个bundle,后面在接口调用)
[HW-Client-Dialer1]ppp chap user ccieh3c
[HW-Client-Dialer1]ppp chap password simple ccieh3c.taobao.com
[HW-Client-Dialer1]ip address ppp-negotiate

(3)接口下调用
[HW-Client]interface e0/0/0
[HW-Client-Ethernet0/0/0]HW-Client dial-bundle-number 1

(4)验证结果

pppoe

可以看到接口已经UP了,说明PPP的协商已经成功

pppoe

地址也已经成功获取。

3、配置NAT(上网使用)+4、默认路由配置

对于在工作上面还会用到的就是NAT配置让内网能够访问internet了。
(1)默认路由配置
[HW-Client]ip route-static 0.0.0.0 0 Dialer 1

(2)NAT配置
[HW-Client]acl number 2000
[HW-Client-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[HW-Client]interface Dialer 1
[HW-Client-Dialer1]nat outbound 2000
说明:这里ACL的含义就是允许哪些网段可以上网,这里为192.168.1.0/24这个网段,然后调用在拨号接口下。

优化部分

对于PPPOE拨号经常容易遇到的一个问题,就是有时候打开一些网页会显示打不开,或者图片不显示的问题。这个的话可以通过把MTU与TCP的MSS修改下就可以了。
建议的话,MTU在1492即可,因为PPPOE会多出8字节的头部,而MSS在1200~1452之间。

[HW-Client]interface Dialer 1
[HW-Client-Dialer1]mtu 1492
[HW-Client-Dialer1]tcp adjust-mss 1452

博主精心分类(附带学习思路哦)

文档帖子汇总,点击查看
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

下载整理好的PDF

↓↓↓↓↓↓↓↓↓↓花些许时间就可以下载实战文档 本地看,安装本站推荐的浏览器,用推荐的浏览器打开对应文章即可下载,觉得文章对您有帮助,记得保留该浏览器哦,下载其他博文可以继续使用,感谢大家支持。(如果对大家有些许帮助,可以每天打开浏览器访问一下本博客,博客会获取推广积分的哦,谢谢)↓↓↓↓↓↓↓↓↓↓

如果下载地址失效,请联系博主或者在下面留言,谢谢。

您使用的不是本站推荐览器浏览!(无法获取下载地址)请点击这里下载安装windows版!(没有下载地址?)

 未标题3.gif

原创与收集的内容,允许转载,转载时请务必以超链接形式标明文章原始出处,博客地址http://ccieh3c.com。

 介绍下载2.jpg
喜欢 (5)
[]
分享 (0)
网络之路
关于作者:
分享一些自己懂的技术知识点,希望对大家有帮助。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址