DHCP:(8)H3C交换机上部署DHCP服务以及DHCP中继功能 | 网络之路博客(公众号同名)(其他平台网络之路Blog)
登录
  • 欢迎网络之路博客网站,分享有用的知识点,公众号:网络之路博客,B站:网络之路Blog
  • 如果您觉得本站对您有帮助,那么赶紧使用Ctrl+D 收藏吧,支持我们下
  • 远程技术支持的淘宝店铺已经开张了哦,传送门:需要的朋友可以点击查看

DHCP:(8)H3C交换机上部署DHCP服务以及DHCP中继功能

【汇总】DHCP原理应用文档

文档帖子汇总实战系列学习视频学习必备软件
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

说明

    之前介绍过华为的交换机,华为的交换机支持两种配置方式,一种基于全局,一种基于接口的形式,很多人认为H3C跟华为一样,确实H3C跟华为很多类似的地方,但是在DHCP方面,定义是不一样,H3C只支持基于全局的方式,并不支持基于接口的,另外防火墙 路由器的配置方式与交换机无异,可以直接参考。

拓扑

dhcp

拓扑说明:有3个VLAN用户,一个VLAN2,另外一个VLAN3,连接二层交换机,二层交换机连接三层交换机,然后连接出口路由器 做NAT,让下面的用户能够访问Internet。这里DHCP的应用在三层交换机上面启用,使得下面的客户机能够获取到地址。

1.二层交换机初始化(配置VLAN,接口划分)
2.三层交换机初始化(配置VLAN以及VLAN接口,接口划分)
3.三层交换机DHCP配置
4.路由器初始化以及其他配置
5.验证
6.查看DHCP地址池情况,以及清空
7.DHCP中继配置

1.二层交换机初始化(配置VLAN,接口划分)

创建VLAN
[Access]vlan 2 to 3

把对应接口加入到VLAN(说明,H3C的接口默认为Access,可以直接在VLAN下添加)
[Access]vlan 2
[Access-vlan2]port Ethernet 0/4/2

[Access]vlan 3
[Access-vlan3]port Ethernet 0/4/3

上行接口对应配置为trunk,允许对应的VLAN通过
[Access]int e0/4/1
[Access-Ethernet0/4/1]port link-type trunk
[Access-Ethernet0/4/1]port trunk permit vlan 2 to 3 (注意华为的为allowd这里为permit)

STP的问题
H3C有些交换机型号STP是关闭的,可以通过display stp brief查看,如果打开了的话,可以在接口下启用边缘端口功能。stp edged-port enable

2.三层交换机初始化(配置VLAN以及VLAN接口,接口划分)

创建对应VLAN
[Core]vlan 2 to 3

下联接入交换机的接口为trunk
[Core]int e0/4/1
[Core-Ethernet0/4/1]port link-type trunk
[Core-Ethernet0/4/1]port trunk permit vlan 2 to 3

VLAN接口创建,VLAN2与3作为PC的网关,VLAN1为路由器连接的接口。
[Core]int vlan 2
[Core-Vlan-interface2]ip address 192.168.2.254 24

[Core]int vlan 3
[Core-Vlan-interface3]ip add 192.168.3.254 24

[Core]int vlan 1
[Core-Vlan-interface1]ip address 192.168.1.1 24

3.三层交换机DHCP配置

开启DHCP功能
[Core]dhcp enable

VLAN2的地址池
[Core]dhcp server ip-pool vlan2
[Core-dhcp-pool-vlan2]network 192.168.2.0 24
[Core-dhcp-pool-vlan2]gateway-list 192.168.2.254
[Core-dhcp-pool-vlan2]dns-list 192.168.2.254
[Core-dhcp-pool-vlan2]domain-name ccieh3c.taobao.com
[Core-dhcp-pool-vlan2]expired day 1

VLAN3地址池
[Core]dhcp server ip-pool vlan3
[Core-dhcp-pool-vlan3]network 192.168.3.0 24
[Core-dhcp-pool-vlan3]gateway-list 192.168.3.254
[Core-dhcp-pool-vlan3]dns-list 114.114.114.114
[Core-dhcp-pool-vlan3]domain-name ccieh3c.taobao.com
[Core-dhcp-pool-vlan3]expired day 1
说明下:这里跟华为差不多,都是定义网段,然后网关,DNS、Domain跟租期,但是是否需要调用的话看版本。
5.X以后的版本包括,新版的7都不需要调用,因为默认在接口下开启了,dhcp select server global-pool 这条命令
,如果发现获取不到地址的话,可以到接口下敲入该命令试试,或者查看对应版本的手册。

[Core]dhcp server forbidden-ip 192.168.2.254
[Core]dhcp server forbidden-ip 192.168.3.254
已经分配的地址做排除。H3C也只支持全局方式,跟思科一样,不支持基于接口形式。

默认路由配置,下面客户机所有的流量都发往出口路由器。
[Core]ip route-static 0.0.0.0 0 192.168.1.2

4.路由器初始化以及其他配置

连接下联三层交换机的接口
[GW]int g0/0
[GW-GigabitEthernet0/0]ip address 192.168.1.2 24

外网接口地址
[GW]int g0/1
[GW-GigabitEthernet0/1]ip address 202.100.1.1 24

去往内网网段的路由
[GW]ip route-static 192.168.2.0 24 192.168.1.1
[GW]ip route-static 192.168.3.0 24 192.168.1.1

访问internet的路由
[GW]ip route-static 0.0.0.0 0 202.100.1.10

NAT配置
[GW]acl number 3000
[GW-acl-adv-3000]rule permit ip source 192.168.2.0 0.0.0.255
[GW-acl-adv-3000]rule permit ip source 192.168.3.0 0.0.0.255

[GW]int g0/1
[GW-GigabitEthernet0/1]nat outbound 3000
说明:路由器上面只需要把路由配置正确,然后ACL规定哪些流量可以通过NAT转换即可,这里使用的是easy-IP的形式。直接转换出接口地址即可。

5.验证

VLAN2的用户
dhcp

VLAN 3用户

dhcp
dhcp
dhcp
dhcp
dhcp

6.查看DHCP地址池情况,以及清空

dhcp

通过display dhcp server ip-in-use all 来查看地址池分配的情况,可以看到现在VLAN 3已经分配了3.1了,MAC地址是图上显示,VLAN 2因为已经测试换到VLAN3里面来了,所以那个已经消失了。

dhcp

也可以通过rset 来清空对应的地址池或者IP、或者所有。

7.DHCP中继配置

这里只讲解下DHCP中继的命令怎么配置,场景已经在第二篇讲解过了,所以这里不在演示。

dhcp

关于博客资源下载说明

首先,感谢大家对网络之路博客的支持,本站所有资源都是开放下载,不做任何限制,资源都是上传在百度盘,分为两种类型:
(1)第一种是书籍PDF与视频类,全部放在博客分享,觉得对大家学习有帮助的博主会收集好、然后以博主的经验整理分类后排序好分享出来。
(2)第二种是技术性文章与视频,全部放在公众号(网络之路博客)/头条号/百家号/B站(网络之路Blog)发布,以博主原创为主,主要分享系列为主,由浅入深的带大家了解工作中常用到的一些网络技术,当然也会分享一些比较经典的案例。
(3)分享资源有涉及到您的利益以及版权问题,请联系博主,24小时候内删除。

想第一时间收到最新更新内容吗,那就赶紧关注公众号/头条/B站/百家号吧~~

学习最新实用技术

远程技术支持(设备调试)

远程技术调试与技术支持,点击查看详情


原创与收集的内容,允许转载,转载时请务必以超链接形式标明文章原始出处,博客地址http://ccieh3c.com。

喜欢 (1)
[]
分享 (0)
公众号:网络之路博客(其他平台网络之路Blog)
分享一些自己懂的技术知识点,希望对大家有帮助。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址