VLAN应用篇系列:(2)Cisco交换机VLAN间路由与传统的单臂路由方式 | 网络之路博客
注册 登录
  • 欢迎网络之路博客网站,分享IT教程,推荐使用2345浏览器访问本网站,可以下载PDF与观看实战文章点击下载
  • 如果您觉得本站对您有帮助,那么赶紧使用Ctrl+D 收藏吧,支持我们下
  • 远程技术支持的淘宝店铺已经开张了哦,传送门:需要的朋友可以点击查看
  • 资源太多??下载繁琐??不知道如何学起??博主给你解决这些问题!~!点击免费下载

VLAN应用篇系列:(2)Cisco交换机VLAN间路由与传统的单臂路由方式

【汇总】通俗易懂学VLAN

文档帖子汇总实战系列学习视频学习必备软件
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

说明

VLAN间路由的方式现在主流的组网主要是依靠三层交换机通过配置SVI接口【有的厂商叫VLANIF接口】,当然也有比较小型的网络,它就一个出口路由器+可管理的二层交换机,还有一种更加差的,就是出口路由+一个可管理的二层交换机,这里以这3种组网方式来讲解下Cisco设备的配置。

场景1

vlan

场景1用的是主流的三层交换机的网络形式,来做VLAN间路由,让PC通过三层交换机能够访问服务器,这里PC客户端在VLAN 2,VLAN 3为服务器区域。

掌握目标

1.两边二层交换机初始化
2.三层交换机初始化与SVI配置
3.验证
4.SVI接口up的几个要点

1.两边二层交换机初始化

(1)、左边交换机配置
【vlan 配置】
SW-1(config)#vlan 2
SW-1(config-vlan)#exit

【接口对应划分进VLAN】
SW-1(config)#int f0/2
SW-1(config-if)#switchport mode access
SW-1(config-if)#switchport access vlan 2

【上行接口】
SW-1(config)#int f0/1
SW-1(config-if)#switchport mode trunk

(2)、右边交换机配置
SW-2(config)#vlan 3
SW-2(config-vlan)#exit

SW-2(config)#int f0/2
SW-2(config-if)#switchport mode access
SW-2(config-if)#switchport access vlan 3

SW-2(config)#
SW-2(config)#int f0/1
SW-2(config-if)#switchport mode trunk

2.三层交换机初始化与SVI配置

SW-3(config)#vlan 2
SW-3(config-vlan)#
SW-3(config-vlan)#vlan 3
SW-3(config-vlan)#exit
SW-3(config)#
SW-3(config)#int range f0/1 – 2
SW-3(config-if-range)#switchport trunk encapsulation dot1q
SW-3(config-if-range)#switchport mode trun
说明:三层交换思科支持ISI与dot1q,所以这里明确指定。
这里没用DHCP功能,可以参考这里:DHCP原理及在企业中的应用

SVI配置

SW-3(config)#interface vlan 2
SW-3(config-if)#ip add 192.168.2.1 255.255.255.0

SW-3(config-if)#int vlan 3
SW-3(config-if)#ip add 192.168.3.1 255.255.255.0
SW-3(config-if)#end

ip routing功能打开,开启三层功能
SW-3(config)#ip routing

3.验证

说明下:PC的IP地址为192.168.2.2,服务器的为192.168.3.2

vlan
vlan

访问服务器与WEB都没问题。

4.SVI接口up的几个要点

1.VLAN 必须在数据库中是Active的
2.二层接口存在Trunk ,这个trunk permit这个VLAN通过 并且是Forwarding状态。
3.该VLAN必须有物理up的接口加入

场景2

vlan

这个场景适合,一个出口路由器支持8021q的,下面交换机是可管理的二层交换机,这个一般被称为单臂路由方式,它比较适合小型网络,因为无论是访问外网还是内网之间的访问都必须通过交换机与路由器的链路来还转发多次,非常容易导致网络的瓶颈。当然如果是多业务路由器,可以自动切换二三层接口,而且可以做SVI,那种更加灵活。

掌握目标

1.二层交换机配置增加【其他引用之前的】
2.出口路由器的内网接口配置
3.验证

1.二层交换机配置增加【其他引用之前的】

SW-1(config)#vlan 3
SW-1(config-vlan)#exit
SW-1(config)#int f0/3
SW-1(config-if)#sw mo ac
SW-1(config-if)#sw ac vlan 3
【这里把服务器加入VLAN4即可,其他的都引用之前的没变。特别说明与路由器连接的接口必须配置为trunk,并且允许特定的VLAN通过,这里思科的默认是全部放行】

2.出口路由器的内网接口配置

SW-Router(config)#int f0/0
SW-Router(config-if)#no shut
SW-Router(config-if)#no shutdown

SW-Router(config-if)#int f0/0.2
SW-Router(config-subif)#encapsulation dot1Q 2
SW-Router(config-subif)#ip address 192.168.2.1 255.255.255.0
SW-Router(config-subif)#
SW-Router(config-subif)#int f0/0.3
SW-Router(config-subif)#encapsulation dot1Q 3
SW-Router(config-subif)#ip add 192.168.3.1 255.255.255.0
SW-Router(config-subif)#end
说明:配置子接口,必须把物理接口打开了,然后进入子接口,封装对应的VLAN,配置IP地址。

3.验证

vlan
vlan

可以看到现在访问还是没有问题。

场景3

vlan

这种环境比较特殊,交换机是傻瓜式交换机,但是有种特殊需求,领导希望你把PC跟服务器的网段不在同一个网段,这个如果是TP这种估计没戏了,思科的话 还有一种解决办法,那就是第二地址。

R1(config)#int f0/0
R1(config-if)#ip add 192.168.2.1 255.255.255.0
R1(config-if)#ip add 192.168.3.1 255.255.255.0 secondary

在接口下配置2个地址即可,不过这个不能应用DHCP技术,必须静态配置IP。这种环境比较少见,不过也是一种解决办法。
总结:对于VLAN间的路由,推荐还是用三层交换机然后来做配置,当然如果只有二层交换机跟出口路由器这种小网络环境的话,那么可以用单臂路由,也就是子接口形式,最后接口多地址的形式比较适合特殊的情况。

博主精心分类(附带学习思路哦)

文档帖子汇总,点击查看
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

如果下载地址失效,请联系博主或者在下面留言,谢谢。

您使用的不是本站推荐览器浏览!(无法获取下载地址)请点击这里下载安装windows版!(没有下载地址?)

 未标题3.gif

原创与收集的内容,允许转载,转载时请务必以超链接形式标明文章原始出处,博客地址http://ccieh3c.com。

 介绍下载2.jpg
喜欢 (4)
[]
分享 (0)
网络之路
关于作者:
分享一些自己懂的技术知识点,希望对大家有帮助。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址