华为路由交换由浅入深系列(八)-交换综合实验(包含Hybrid,MAC VLAN、三层路由及单臂路由) | 网络之路博客(公众号同名)(其他平台网络之路Blog)
登录
  • 欢迎网络之路博客网站,分享有用的知识点,公众号:网络之路博客,B站:网络之路Blog
  • 如果您觉得本站对您有帮助,那么赶紧使用Ctrl+D 收藏吧,支持我们下
  • 远程技术支持的淘宝店铺已经开张了哦,传送门:需要的朋友可以点击查看

华为路由交换由浅入深系列(八)-交换综合实验(包含Hybrid,MAC VLAN、三层路由及单臂路由)

【汇总】华为路由交换由浅入深系列

文档帖子汇总学习视频实战系列学习必备软件
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

说明

华为路由交换由浅入深系列(八)-交换综合实验(包含HybridMAC VLAN三层路由单臂路由

实验拓扑:

huawei

对于华为的Access、Trunk、Hybrid接口处理数据报文不清楚的朋友可以看该说明
《交换机三种端口模式Access、Hybrid和Trunk的理解》,前面有

lsw1实验配置:

[lsw1]dis cu
#
sysname lsw1
#
vlan batch 10 20 30 40 110 120 199
#
dhcp enable
# (这里是三层交换的配置,可以替换成单臂路由的配置,见最后)
interface Vlanif10
ip address 192.168.10.1 255.255.255.0
dhcp select interface
dhcp server dns-list 8.8.8.8
#
interface Vlanif20
ip address 192.168.20.1 255.255.255.0
dhcp select interface
dhcp server dns-list 8.8.8.8
#
interface Vlanif30
ip address 192.168.30.1 255.255.255.0
dhcp select interface
dhcp server dns-list 8.8.8.8
#
interface Vlanif40
ip address 192.168.40.1 255.255.255.0
dhcp select interface
dhcp server dns-list 8.8.8.8
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#(这里演示的hybrid 接口的使用场景,配置完后接口57可以通,接口67可以通,接口56不能通信)
interface GigabitEthernet0/0/5
port hybrid pvid vlan 110
port hybrid untagged vlan 110 199
#
interface GigabitEthernet0/0/6
port hybrid pvid vlan 120
port hybrid untagged vlan 120 199
#
interface GigabitEthernet0/0/7
port hybrid pvid vlan 199
port hybrid untagged vlan 110 120 199
#

lsw2实验配置

dis cu
#
sysname lsw2
#
vlan batch 10 20
#
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/2
port link-type access
port default vlan 10
#
interface Ethernet0/0/3
port link-type access
port default vlan 20
#
lsw3实验配置:
dis cu
#
sysname lsw3
#
vlan batch 10 20
#
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/2
port link-type access
port default vlan 10
#
interface Ethernet0/0/3
port link-type access
port default vlan 20
#

lsw4实验配置

dis cu
#
sysname lsw4
#(这里演示的基于MAC来划分VLAN的方法)
vlan batch 30 40
#
vlan 30
mac-vlan mac-address 000b-09cf-6f43 priority 0
vlan 40
mac-vlan mac-address 000b-09cf-7f5f priority 0
#
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 30 40
#
interface Ethernet0/0/2
port hybrid untagged vlan 30 40
mac-vlan enable
#
interface Ethernet0/0/3
port hybrid untagged vlan 30 40
mac-vlan enable

实验验证

1 接入层交换机上所有client 123456设置成DHCP地址方式,可以分别得到vlan 10 20 30 40 vlan 的ip并可以相互通信(VLAN Trunk VLAN路由及DHCP功能 )。
2 分布层交换机上的client 7 和client 9 可以通信,client 8 和client 9 可以通信,client 7 和client 8不能通信(hybrid 接口功能)
3 对换client 5 和client 6的接口,PC的vlan和IP保持不变(MAC VLAN功能)

huawei

附加——路由器的单臂路由的配置

[R1]dis current-configuration
#
sysname R1
#
dhcp enable
#
interface Ethernet0/0/0
undo shutdown
#
interface Ethernet0/0/0.10
control-vid 10 dot1q-termination
dot1q termination vid 10
ip address 192.168.10.1 255.255.255.0
arp broadcast enable
dhcp select interface
dhcp server dns-list 8.8.8.8

interface Ethernet0/0/0.20
control-vid 20 dot1q-termination
dot1q termination vid 20
ip address 192.168.20.1 255.255.255.0
arp broadcast enable
dhcp select interface
dhcp server dns-list 8.8.8.8

interface Ethernet0/0/0.30
control-vid 30 dot1q-termination
dot1q termination vid 30
ip address 192.168.30.1 255.255.255.0
arp broadcast enable
dhcp select interface
dhcp server dns-list 8.8.8.8

interface Ethernet0/0/0.40
control-vid 40 dot1q-termination
dot1q termination vid 40
ip address 192.168.40.1 255.255.255.0
arp broadcast enable
dhcp select interface
dhcp server dns-list 8.8.8.8

下载对应文档

百度盘下载博客资源汇总与学习思路
如果下载地址失效,请联系博主或者在下面留言,谢谢。下面也有其他您需要的资源推荐哦

关于博客资源下载说明

首先,感谢大家对网络之路博客的支持,本站所有资源都是开放下载,不做任何限制,资源都是上传在百度盘,分为两种类型:
(1)第一种是书籍PDF与视频类,全部放在博客分享,觉得对大家学习有帮助的博主会收集好、然后以博主的经验整理分类后排序好分享出来。
(2)第二种是技术性文章与视频,全部放在公众号(网络之路博客)/头条号/百家号/B站(网络之路Blog)发布,以博主原创为主,主要分享系列为主,由浅入深的带大家了解工作中常用到的一些网络技术,当然也会分享一些比较经典的案例。
(3)分享资源有涉及到您的利益以及版权问题,请联系博主,24小时候内删除。

想第一时间收到最新更新内容吗,那就赶紧关注公众号/头条/B站/百家号吧~~

学习最新实用技术

远程技术支持(设备调试)

远程技术调试与技术支持,点击查看详情


原创与收集的内容,允许转载,转载时请务必以超链接形式标明文章原始出处,博客地址http://ccieh3c.com。

喜欢 (3)
[]
分享 (0)
公众号:网络之路博客(其他平台网络之路Blog)
分享一些自己懂的技术知识点,希望对大家有帮助。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址