由浅入深玩转华为WLAN—17 漫游系列(4)同一AC内AP之间三层漫游【拓扑介绍以及初始化配置】 | 网络之路博客(公众号同名)(其他平台网络之路Blog)
登录
  • 欢迎网络之路博客网站,分享有用的知识点,公众号:网络之路博客,B站:网络之路Blog
  • 如果您觉得本站对您有帮助,那么赶紧使用Ctrl+D 收藏吧,支持我们下
  • 远程技术支持的淘宝店铺已经开张了哦,传送门:需要的朋友可以点击查看

由浅入深玩转华为WLAN—17 漫游系列(4)同一AC内AP之间三层漫游【拓扑介绍以及初始化配置】

【汇总】实战华为无线

文档帖子汇总实战系列学习视频学习必备软件
    博主也只是业余时间写写技术文档,请大家见谅,大家觉得不错的话,可以推荐给朋友哦,博主会努力推出更好的系列文档的。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,http://ccieh3c.com

简介

上次介绍了二层漫游与初始化配置,最后的WLAN业务与漫游的演示,包括了在工作环境下如果遇到了漫游后业务不通的状况出现,如何分析以及解决,这次主要介绍三层漫游,以及拓扑介绍跟初始化配置

这次不介绍漫游跟AC里面的具体配置,主要讲解拓扑初始化的配置,涉及到的内容也挺多的,所以分为2篇写,这篇介绍拓扑,以及各个设备上面的初始化配置,下一篇主要介绍AC上面的WLAN相关的配置。

同一AC的三层漫游:指的是在同一个AC下面的不同AP之间不同业务之间的漫游(跨越三层网络),比如图中AP-1的业务VLAN 是10(192.168.10.0/24),而AP-2的业务VLAN是20(192.168.20.0/24),无线客户端从AP-1漫游到AP-2后,虽然处于AP-2上面,但是业务VLAN保持不变,IP地址也保持不变,只是由原先的AP-1变成了AP-2来转发无线客户端的业务。

wireless

拓扑说明

wireless

说明:该拓扑就一个办公区域,AP-1主要提供给转发VLAN 101的业务,而AP-2主要提供转发VLAN 102的业务,但是领导希望在办公区域内,客户端能够进行自动的切换关联,希望保持在比较不错的信号强度的AP下转发业务,这时候必须提供三层漫游功能来实现这个目的了。

管理VLAN 800:192.168.80.0/24 GW:192.168.80.254
业务VLAN 101:192.168.101.0/24 GW:192.168.101.254
业务VLAN 102:192.168.102.0/24 GW:192.168.101.254
与路由器对接接口VLAN 1:192.168.1.0/24 交换机地址:192.168.1.1 路由器内网地址:192.168.1.2
与AC对接的接口 VLAN 100:192.168.100.1/24 AC源接口地址:192.68.100.2/24
隧道转发模式:直接转发
AP上线组网方式:三层(不在一个子网广播域内),必须通过DHCP Option43来实现
SSID:Intranet 认证与加密方式:WPA2 PSK+CCMP
AP-1主要提供业务VLAN 101(也提供VLAN 102的业务转发)
AP-2主要提供业务VLAN 102(也提供VLAN 101的业务转发)
说明:这里AP肯定得为2个业务VLAN 能够提供转发才行,否则的话 三层漫游多个业务VLAN之间AP需要能够识别的了,能够打上业务TAG。

掌握目标

1、POE二层交换机初始化(包括VLAN创建,Trunk链路定义)
2、核心交换机定义(包括VLAN创建,Trunk链路定义,DHCP,VLANIF接口以及路由)
3、出口路由配置(包含内外网接口+路由以及NAT服务)
4、AC初始化(包括VLAN的Trunk,以及VLANIF接口创建)

1、POE二层交换机初始化(包括VLAN创建,Trunk链路定义)

说明:需要配置的VLAN为100~101,其中VLAN 100为管理VLAN,而VLAN 101为业务VLAN,Trunk链路定义在连接AP跟上行核心交换机上面(直接转发模式下是需要定义Trunk跟hybrid接口,主要管理VLAN需要通过,而且业务VLAN也需要通过,多VLAN的情况下。)

AS-1设备
【创建VLAN】
[Huawei-AS-1]vlan batch 101 102 800

【Trunk链路定义】
接口AP-1的接口
[Huawei-AS-1]int e0/0/1
[Huawei-AS-1-Ethernet0/0/1]port link-type trunk
[Huawei-AS-1-Ethernet0/0/1]port trunk pvid vlan 800
[Huawei-AS-1-Ethernet0/0/1]port trunk allow-pass vlan 101 to 102 800

接AP-2的接口
[Huawei-AS-1-Ethernet0/0/1]int e0/0/3
[Huawei-AS-1-Ethernet0/0/3]port link-type trunk
[Huawei-AS-1-Ethernet0/0/3]port trunk pvid vlan 800
[Huawei-AS-1-Ethernet0/0/3]port trunk allow-pass vlan 101 to 102 800
说明:这里PVID是给AP打上管理VLAN,然后允许了业务VLAN 101 102与管理VLAN 800通过,因为涉及到漫游,所以AP提供多种业务VLAN的转发,所以必须放行。

接口交换机的接口
[Huawei-AS-1]int e0/0/2
[Huawei-AS-1-Ethernet0/0/2]port link-type trunk
[Huawei-AS-1-Ethernet0/0/2]port trunk allow-pass vlan 101 to 102 800
说明:接AP的接口由于管理VLAN是100,所以这里必须把PVID定义为100,这样当AP管理帧发出来的时候,没有VLAN ID,所以会打上PVID VLAN 100,然后允许VLAN 100与101通过即可。

2、核心交换机定义(包括VLAN创建,Trunk链路定义,DHCP,VLANIF接口以及路由)

【创建VLAN】
[Huawei-Core-SW]vlan batch 100 to 102 800

【接接入交换机的接口】
[Huawei-Core-SW]int g0/0/2
[Huawei-Core-SW-GigabitEthernet0/0/2]port link-type trunk
[Huawei-Core-SW-GigabitEthernet0/0/2]port trunk allow-pass vlan 101 to 102 800

【接AC的接口】
[Huawei-Core-SW]int g0/0/4
[Huawei-Core-SW-GigabitEthernet0/0/4]port link-type access
[Huawei-Core-SW-GigabitEthernet0/0/4]port default vlan 100

【接出口路由器的接口】
那个默认属于VLAN 1,所以不需要划入
总结:总共配置了2个接口,一个是对接接入交换机的接口,它需要为trunk,放行对应的管理VLAN流量以及业务VLAN流量通过,而接AC的接口,由于是直连转发,所以这里只需要对接一个地址即可,能够跟AC通信。

【开启DHCP功能】
[Huawei-Core-SW]dhcp enable

【创建VLANIF接口】
与AC对接的VLANFI接口
[Huawei-Core-SW]int vlan 100
[Huawei-Core-SW-Vlanif100]ip address 192.168.100.1 24

业务VLAN 101的VLANIF接口
[Huawei-Core-SW]int vlan 101
[Huawei-Core-SW-Vlanif101]ip address 192.168.101.254 24
[Huawei-Core-SW-Vlanif101]dhcp select interface
[Huawei-Core-SW-Vlanif101]dhcp server dns-list 114.114.114.114
[Huawei-Core-SW-Vlanif101]dhcp server domain-name ccieh3c.taobao.com

VLAN业务102的VLANIF接口
[Huawei-Core-SW]interface vlan 102
[Huawei-Core-SW-Vlanif102]ip address 192.168.102.254 24
[Huawei-Core-SW-Vlanif102]dhcp select interface
[Huawei-Core-SW-Vlanif102]dhcp server dns-list 114.114.114.114
[Huawei-Core-SW-Vlanif102]dhcp server domain-name ccieh3c.taobao.com

管理VLAN的VLANIF接口(注意,这里是三层组网跟AC的源接口不在同一个网段,需要用到Option43)
[Huawei-Core-SW]int vlan 800
[Huawei-Core-SW-Vlanif800]ip address 192.168.80.254 24
[Huawei-Core-SW-Vlanif800]dhcp select interface
[Huawei-Core-SW-Vlanif800]dhcp server option 43 sub-option 3 ascii 192.168.100.2

与出口路由器对接的VLANIF接口
[Huawei-Core-SW]int vlan 1
[Huawei-Core-SW-Vlanif1]ip address 192.168.1.1 24

【路由定义】
[Huawei-Core-SW]ip route-static 0.0.0.0 0 192.168.1.2
说明:这里只需要一个默认路由即可,用来访问Internet。

说明:VLANIF1的接口用来与出口路由器对接,VLANIF 100的与AC对接,而VLAN 101与102则是提供给业务的网关,VLAN 800是AP的管理VLAN,由于管理VLAN与AC的源接口地址不在同一个网络,所以必须启用Option43来告诉AP,AC在哪。

3、出口路由配置(包含内外网接口+路由以及NAT服务)

【定义内外网接口】
[Huawei-GW]int g0/0/0
[Huawei-GW-GigabitEthernet0/0/0]ip address 192.168.1.2 24

[Huawei-GW]int g0/0/1
[Huawei-GW-GigabitEthernet0/0/1]ip address 202.100.1.1 24

【定义路由】
[Huawei-GW]ip route-static 192.168.101.0 24 192.168.1.1
[Huawei-GW]ip route-static 192.168.102.0 24 192.168.1.1
[Huawei-GW]ip route-static 0.0.0.0 0 202.100.1.2
说明:第一、二条路由是回程路由,用来当192.168.101.0/102.0的数据返回的时候直到怎么发送,第二条路由则发往Internet访问的。

【NAT配置】
[Huawei-GW]acl number 3000
[Huawei-GW-acl-adv-3000]rule permit ip source 192.168.101.0 0.0.0.255
[Huawei-GW-acl-adv-3000]rule permit ip source 192.168.102.0 0.0.0.255

[Huawei-GW]int g0/0/1
[Huawei-GW-GigabitEthernet0/0/1]nat outbound 3000
说明:定义ACL 3000就是用来匹配192.168.101.0/24的网段流量,然后在出接口调用,匹配了ACL里面定义的流量就做源PAT转换,简称easy-ip。

4、AC初始化(包括VLAN的Trunk,以及VLANIF接口创建)

【创建VLAN 】
[Huawei-AC]vlan 100
说明:创建VLAN 100即可

【定义二层接口,与核心交换机连接的接口】
[Huawei-AC]int g0/0/4
说明:这里与核心交换对接的接口,划入到VLAN 100即可

【定义VLAN IF接口】
[Huawei-AC]int vlan 100
[Huawei-AC-Vlanif100]ip address 192.168.100.2 24

[Huawei-AC]ip route-static 0.0.0.0 0 192.168.100.1
这里必须有路由能够访问到800,可以是静态也可以是默认。

总结:目前为止,整个网络的网络初始化已经完毕,从接入交换机的VLAN划分以及接口类型配置,到核心交换机的初始化,VLANIF创建跟DHCP与路由,出口路由器的路由 NAT等,这些初始化的目的主要是为了让整个网络能够通信起来,比如AP能获取到地址与AC建立CAPWAP隧道,当WLAN业务部署起来后,无线客户端关联后获取到地址能够正常访问其他内网或者外网。
下一篇介绍三层漫游的WLAN配置包括验证。

源文件:http://pan.baidu.com/s/1qYH6ha8

关于博客资源下载说明

首先,感谢大家对网络之路博客的支持,本站所有资源都是开放下载,不做任何限制,资源都是上传在百度盘,分为两种类型:
(1)第一种是书籍PDF与视频类,全部放在博客分享,觉得对大家学习有帮助的博主会收集好、然后以博主的经验整理分类后排序好分享出来。
(2)第二种是技术性文章与视频,全部放在公众号(网络之路博客)/头条号/百家号/B站(网络之路Blog)发布,以博主原创为主,主要分享系列为主,由浅入深的带大家了解工作中常用到的一些网络技术,当然也会分享一些比较经典的案例。
(3)分享资源有涉及到您的利益以及版权问题,请联系博主,24小时候内删除。

想第一时间收到最新更新内容吗,那就赶紧关注公众号/头条/B站/百家号吧~~

学习最新实用技术

远程技术支持(设备调试)

远程技术调试与技术支持,点击查看详情


原创与收集的内容,允许转载,转载时请务必以超链接形式标明文章原始出处,博客地址http://ccieh3c.com。

喜欢 (0)
[]
分享 (0)
公众号:网络之路博客(其他平台网络之路Blog)
分享一些自己懂的技术知识点,希望对大家有帮助。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址